Skip to main content
Have a personal or library account? Click to login
Interoperable CSV for Environmental Data Archival and Exchange: iCSV Cover

Interoperable CSV for Environmental Data Archival and Exchange: iCSV

Open Access
|Oct 2026

References

  1. Attribute Convention for Data Discovery 1-3 (2023) Earth Science Information Partners (ESIP). Available at: https://wiki.esipfed.org/Attribute_Convention_for_Data_Discovery_1-3 (visited on 05/22/2025).
  2. Batista, D. et al. (2022) ‘Machine actionable metadata models’, Scientific Data, 9(1). Available at: 10.1038/s41597-022-01707-6
  3. Bavay, M. ( 2021) ‘Format specification for the SMET Weather Station Meteorological Data Format version 1.2’. https://meteoio.slf.ch/doc-dev/html/smetio.html
  4. Bavay, M. and Egger, T. (2014) ‘MeteoIO 2.4.2: a preprocessing library for meteorological data’, Geoscientific Model Development, 7(6): pp. 3135–3151. Available at: 10.5194/gmd-7-3135-2014.
  5. Bavay, M., Fiddes, J. and Godøy, Ø. (2020) ‘Automatic data standardization for the global cryosphere watch data portal’, Data Science Journal, 19(1): pp. 1–8. Available at: 10.5334/dsj-2020-006
  6. Bergès, J.C. (2002) ‘Support of WMO binary format (BUFR and GRIB)’. Proceedings of the Open source GIS-GRASS user conference, Trento, Italy. Vol. 11, p. 13.
  7. Boehm, M. (2025) ‘Technical perspective: TASHEEH: repairing row-structure in raw CSV files’, ACM SIGMOD Record, 54(1): pp. 89. Available at: 10.1145/3733620.3733638
  8. Bratt, S. et al. (2017) ‘Big data, big metadata and quantitative study of science: A workflow model for big scientometrics’, Proceedings of the Association for Information Science and Technology, 54(1): pp. 36–45. Available at: 10.1002/pra2.2017.14505401005
  9. Butchart, S.H.M. et al. (2010) ‘Global biodiversity: indicators of recent declines’, Science, 328(5982): pp. 1164–1168. Available at: 10.1126/science.1187512.
  10. Caron, J. and Oxelson, J. (2013) ‘BUFR and GRIB file formats considered harmful for data archiving’. In: EGU general assembly conference abstracts, EGU2013–1961. Göttingen, Germany: Copernicus Publications. https://ui.adsabs.harvard.edu/abs/2013EGUGA.15.1961C/abstract
  11. Chacon, S. and Straub, B. (2014) Pro git. Berkeley, CA: Apress. Available at: 10.1007/978-1-4842-0076-6
  12. Collet, Y. and Kucherawy, M. (2021) Zstandard Compression and the ‘application/zstd’ Media Type. RFC 8878. Available at: 10.17487/RFC8878
  13. Deutsch, P. (1996) DEFLATE Compressed Data Format Specification version 1.3. RFC 1951. Available at: 10.17487/RFC1951
  14. Fagundes, M.F. and Ribeiro, D.I. Junior (2020) ‘Frictionless Data-based model applied to open government data’, RDBCI: Revista Digital de Biblioteconomia e Ciência da Informação, 18: p. e020034. Available at: 10.20396/rdbci.v18i00.8661528
  15. Fierz, C. et al. (2016) ‘SnopViz, an interactive visualization tool for both snow-cover model output and observed snow profiles’. Proceedings of the International Snow Science Workshop, CO, pp. 3–7. Available at: https://arc.lib.montana.edu/snow-science/objects/ISSW16_P1.29.pdf.
  16. Folk, M. et al. (2011) ‘An overview of the HDF5 technology suite and its applications’. Proceedings of the EDBT/ICDT 2011 Workshop on Array Databases. AD ‘11. New York, NY, USA: Association for Computing Machinery, pp. 36–47. Available at: 10.1145/1966895.1966900
  17. Frei, E.R. et al. (2023) Long-term meteorological station Stillberg, Davos, Switzerland at 2090 m a.s.l. Available at: 10.16904/envidat.396. url: https://www.envidat.ch/dataset/meteo-stillberg.
  18. Gupta, J. et al. (2023) ‘Earth system justice needed to identify and live within Earth system boundaries’, Nature Sustainability, 6(6): pp. 630–638. Available at: 10.1038/s41893-023-01064-1
  19. Hameed, M., Vitagliano, G., Panse, F. and Naumann F. (2024) ‘TASHEEH: Repairing Row-Structure in Raw CSV Files.’, International Conference on Extending Database Technology. https://api.semanticscholar.org/CorpusID:268554663
  20. Hankin, S. et al. (2009) ‘NetCDF-CF-OPeNDAP: Standards for ocean data interoperability and object lessons for community data standards processes’. Proceedings of OceanObs’09: Sustained Ocean Observations and Information for Society. Available at: https://www.oceanobs09.net/proceedings/cwp/Hankin-OceanObs09.cwp.41.pdf
  21. Hart, E. et al. (2016) ‘Ten simple rules for digital data storage’, PeerJ Preprints, 4: p. e1448v2. Available at: 10.7287/peerj.preprints.1448v2
  22. Hassell, D. et al. (2017) ‘A data model of the Climate and Forecast metadata conventions (CF-1.6) with a software implementation (cf-python v2.1)’, Geoscientific Model Development, 10(12): pp. 4619–4646. Available at: 10.5194/gmd-10-4619-2017
  23. Herring, J.R. (2011) OpenGIS Implementation Standard for Geographic information - Simple feature access - Part 1: Common architecture. Version 1.2.1. Available at: https://www.opengis.net/doc/is/sfa/1.2.1 (visited on 06/29/2026).
  24. IAGA 2002 Data Exchange Format (2026) Version June-2015. Available at:: https://www.ncei.noaa.gov/services/world-data-system/v-dat-working-group/iaga-2002-data-exchange-format (visited on 06/29/2026).
  25. Karhila, V. and Hernandez-Carrascal, A. (2010) ‘BUFR: a meteorological code for the 21st century’. 2010 EUMETSAT Meteorological Satellite Conference, Cordoba, Spain, Vol. 5.
  26. Key, J. et al. (2016) Global Cryosphere Watch (GCW) Implementation Plan. Tech. rep. World Meteorological Organization. Available at: https://library.wmo.int/idurl/4/55518.
  27. Kirchhoff, J., Gottschalk, S. and Engels, G. (2022) ‘Detecting Data Incompatibilities in Process-Driven Decision Support Systems’, in: Business modeling and software design. New York: Springer International Publishing, pp. 89–103. Available at: 10.1007/978-3-031-11510-3_6
  28. Kitchin, R. (2014) ‘Big Data, new epistemologies and paradigm shifts’, Big Data & Society, 1(1). Available at: 10.1177/2053951714528481
  29. Leibersperger, P. (2024) SNOWPAT. Available at: https://snowpat.slf.ch/ (visited on 05/22/2025).
  30. Manual on codes. International codes. volumes I.2 & 1.2 (2009) 2009 ed. OCLC: 607526193. Geneva, Switzerland: Secretariat of the World Meteorological Organization.
  31. Michna, P. and Woods, M. (2013) ‘RNetCDF - A Package for Reading and Writing NetCDF Datasets’, The R Journal, 5(2): p. 29. Available at: 10.32614/rj-2013-023
  32. Mitlöhner, J. et al. (2016) ‘Characteristics of Open Data CSV Files’, 2nd International Conference on Open and Big Data (OBD). IEEE. Available at: 10.1109/obd.2016.18.
  33. Non-Binary Environmental Archive Data (NEAD) format - EnviDat (2024) Available at: https://www.envidat.ch/dataset/nead (visited on 05/10/2024).
  34. Núñez, C. (2026) DEVO: Data Enrichment and Validation Orchestrator. Version 0.2.2. Available at: https://github.com/chasenunez/devo (visited on 07/03/2026).
  35. Pandas, Development Team (Feb. 2020) pandas-dev/pandas: Pandas. Version latest. Available at: 10.5281/zenodo.3509134
  36. Parton, G.A. and Pepler, S. (2009) The BADC-CSV Format: Meeting user and metadata requirements. Available at: 10.5281/zenodo.7355840
  37. Petti, S. (2023) ‘A better governance for the Frictionless Standards’. In: Submitted to Open Infrastructure Fund / Fondo de Infraestructura Abierta. Available at: https://openreview.net/forum?id=02iXOVKoPo.
  38. Petti, S. and Karev, E. (2022) ‘Frictionless Data Standards’. In: Commonplace. Available at: 10.21428/6ffd8432.1619ad93
  39. Plantin, J.-C., Lagoze, C. and Edwards, P.N. (2018) ‘Re-integrating scholarly infrastructure: the ambiguous role of data sharing platforms’, Big Data & Society, 5(1). Available at: 10.1177/2053951718756683
  40. Rew, R. and Davis, G. (1990) ‘NetCDF: an interface for scientific data access’, IEEE Computer Graphics and Applications, 10(4): pp. 76–82. Available at: 10.1109/38.56302
  41. Rixen, C. et al. (2014) ‘Faster, higher, more? Past, present and future dynamics of alpine and arctic flora under climate change’, Alpine Botany, 124(2): pp. 77–79. Available at: 10.1007/s00035-014-0141-z
  42. Romano, D. (1997) ‘Data mining leading edge: Insurance & banking’, In: Proceedings of Knowledge Discovery and Data Mining, Unicom, Brunel University.
  43. Seward, J. (1996) ‘bzip2 and libbzip2’. pp. 8–18. Available at: https://www.bzip.org.
  44. Shafranovich, Y. (2005) Common Format and MIME Type for Comma-Separated Values (CSV) Files. Request for Comments RFC 4180. Num Pages: 8. Internet Engineering Task Force. Available at: 10.17487/RFC4180. url: https://datatracker.ietf.org/doc/rfc4180 (visited on 05/10/2024).
  45. Tenopir, C. et al. (2020) ‘Data sharing, management, use, and reuse: Practices and perceptions of scientists worldwide’, PLOS ONE, 15(3): p. e0229003. Available at: 10.1371/journal.pone.0229003
  46. van den Burg, G.J.J., Názábal, A. and Sutton, C. (2019) ‘Wrangling messy CSV files by detecting row and type patterns’, Data Mining and Knowledge Discovery, 33(6): pp. 1799–1820. Available at: 10.1007/s10618-019-00646-y
  47. Wever, N. (2017) WFJ_MOD: Meteorological and snowpack measurements from Weissfluhjoch, Davos, Switzerland. Available at: 10.16904/1. url: https://www.envidat.ch/dataset/10-16904-1.
  48. Wilkinson, M.D. et al. (2016) ‘The FAIR Guiding Principles for scientific data management and stewardship’, Scientific Data, 3(1). Available at: 10.1038/sdata.2016.18
  49. Yang, M. et al. (2019) ‘An efficient storage and service method for multi-source merging meteorological big data in cloud environment’, EURASIP Journal on Wireless Communications and Networking, 2019(1). Available at: 10.1186/s13638-019-1576-0
  50. Zhang, Y. et al. (2023) ‘Multi-sensor integration management in the earth observation sensor web: State-of-the-art and research challenges’, International Journal of Applied Earth Observation and Geoinformation, 125: p. 103601. Available at: 10.1016/j.jag.2023.103601
  51. Ziv, J. and Lempel, A. (1978) ‘Compression of individual sequences via variable-rate coding’, IEEE transactions on Information Theory, 24(5): pp. 530–536. Available at: 10.1109/TIT.1978.1055934
  52. Zuiderwijk, A., Jeffery, K. and Janssen, M. (2012) ‘The Potential of Metadata for Linked Open Data and its Value for Users and Publishers’, JeDEM – eJournal of eDemocracy and Open Government, 4(2): pp. 222–244. Available at: 10.29379/jedem.v4i2.138
Language: English
Page range: 39 - 39
Submitted on: Feb 12, 2026
Accepted on: Oct 5, 2026
Published on: Oct 22, 2026
Published by: Ubiquity Press
In partnership with: Paradigm Publishing Services

© 2026 Patrick Leibersperger, Mathias Bavay, Ionut Iosifescu Enescu, Chase Núñez, published by Ubiquity Press
This work is licensed under the Creative Commons Attribution 4.0 License.